Was sind die FrontPage-Servererweiterungen?

Bei den FrontPage-Servererweiterungen handelt es sich um drei Programme, deren Routinen mehrere nützliche Aufgaben für diejenigen durchführen, die verwalten, erstellen und anzeigen. Ohne die Servererweiterungen könnten einige dieser Aufgaben nicht oder nicht so leicht durchgeführt werden.

Die Servererweiterungen können leicht auf allen verbreiteten Betriebssystemen, wie z. B. Microsoft Windows NT Server, Digital UNIX und SunOS, installiert werden, wodurch eine plattformübergreifende Kompatibilität der Webserver ermöglicht wird. Die Servererweiterungen unterstützen darüber hinaus die meisten verbreiteten Webserver, wie z. B. Microsoft Internet Information Services (IIS), Netscape und WebSite, sowie Freeware- und Shareware-Webserver, wie z. B. die von Stronghold und NCSA.

Die Verwaltung der FrontPage-Servererweiterungen erfolgt indirekt. Stattdessen verwenden Sie eines von mehreren Tools mit überlappender Funktionalität, um mit ihnen zu arbeiten. Eines dieser Tools ist das FrontPage-MMC-Snapin.

Ausführlichere Informationen zu den FrontPage-Servererweiterungen finden Sie im Resource-Kit für FrontPage-Servererweiterungen unter http://www.microsoft.com/frontpage/wpp/serk. Wenn die FrontPage-Servererweiterungen auf dem Computer installiert sind, können Sie auch auf das Resource-Kit für FrontPage-Servererweiterungen zugreifen, das standardmäßig in C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\version4.0\serk\nnnn\default.htm installiert wird. Der Ordner \nnnn besitzt einen nummerischen Namen, der von der Sprache abhängt, in der die FrontPage-Servererweiterungen installiert wurden. Bei einer US-englischen Installation beispielweise lautet der Pfad C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\version4.0\serk\1033\default.htm.


Die Vorteile der Verwendung der FrontPage-Servererweiterungen

Die FrontPage-Servererweiterungen erleichtern es Webautoren, in ihren Websites komplexe Funktionen zu realisieren, und Webadministratoren, die jeweilige Funktionalität zu unterstützen. Die Servererweiterungen

  • ermöglichen es Autoren, beim Erstellen und Verwalten einer zusammenzuarbeiten, eine Website direkt auf dem Servercomputer zu bearbeiten (und die Zeit für den Download zu sparen) sowie auf einfache Weise und ohne Programmierung Funktionen zu den Websites hinzuzufügen.
  • unterstützen Zugriffszähler, Volltextsuchen, Behandlungsroutinen für E-Mail-Formulare und andere Funktionen, die ein Autor mit Hilfe von FrontPage zu einer Website hinzufügen kann. Ein Download, Kauf oder Installieren eines eigenständigen -kompatiblen Programms ist nicht erforderlich, um ein Funktionieren der Funktionen zu ermöglichen,
  • arbeiten auf einer Vielzahl von verbreiteten Serverplattformen, wie z. B. Windows NT und UNIX, sowie auf einer Vielzahl verbreiteter Webserver, wie z. B. Microsoft Internet Information Services (IIS), WebSite und Netscape,
  • aktualisieren Hyperlinks automatisch, nachdem eine Seite in einer Website verschoben, gelöscht oder umbenannt wurde (lediglich der Dateiname der Seite, und nicht die gesamte Datei, muß an den Webserver übertragen werden),
  • unterstützt die Integration mit Microsoft Office, Visual SourceSafe und Index Server.


Wissenswertes zum FrontPage-MMC-Snapin

Beim FrontPage-MMC-Snapin handelt es sich um ein Programm, das nur unter Windows ausgeführt werden kann und mit dem Sie die FrontPage-Servererweiterungen und verwalten können. Sie können es zum von , Erstellen von , Aktualisieren der Servererweiterungen auf einem Web, Konvertieren von Ordnern in Unterwebs und umgekehrt, Neuberechnen von Hyperlinks in einem und eine Vielzahl weiterer Aktionen verwenden.

Das FrontPage-MMC-Snapin „klinkt sich“ in Microsoft Management Console (MMC) ein, d. h. dass Befehle, Eigenschaftenseiten und andere Tools, die zum Verwalten der FrontPage-Servererweiterungen erforderlich sind, zur MMC-„Shell“ hinzugefügt werden. Darüber hinaus entsprechen das Aussehen und die Funktionsweise der Tools des FrontPage-MMC-Snapins den anderen Tools in der .

Wenn Microsoft Internet Information Services (IIS), Version 4.0 oder höher, auf einem Computer installiert ist, „klinkt sich“ das FrontPage-MMC-Snapin in das IIS-Snapin ein und fügt seine Funktionalität zum IIS-Snapin hinzu. Falls ein anderer Webserver als IIS, Version 4.0 oder höher, installiert ist, erweitert das FrontPage-MMC-Snapin direkt die Funktionalität der Konsole. Alle Tools, die Sie zum Verwalten einer benötigen, befinden sich an einer geeigneten Stelle.

Das FrontPage-MMC-Snapin ersetzt und verbessert das Dienstprogramm Fpsrvwin, ein Verwaltungsprogramm, das in früheren Versionen von FrontPage enthalten war, erheblich. Sie können mit dem FrontPage-MMC-Snapin die meisten Verwaltungsaufgaben durchführen, die Sie mit den Dienstprogrammen Fpsrvwin, Fpsrvadm und Fpremadm durchführen können, sowie einige zusätzliche Aufgaben.

Weitere Informationen zum Einsatz von Fpsrvadm und Fpremadm zum Verwalten der FrontPage-Servererweiterungen finden Sie im Resource-Kit für FrontPage-Servererweiterungen unter http://www.microsoft.com/frontpage/wpp/serk. Wenn die FrontPage-Servererweiterungen auf dem Computer installiert sind, können Sie auch auf das Resource-Kit für FrontPage-Servererweiterungen zugreifen, das standardmäßig in C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\version4.0\serk\nnnn\default.htm installiert wird. Der Ordner \nnnn besitzt einen nummerischen Namen, der von der Sprache abhängt, in der die FrontPage-Servererweiterungen installiert wurden. Bei einer US-englischen Installation lautet der Pfad beispielsweise C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\version4.0\serk\1033\default.htm.


Das FrontPage-MMC-Snapin ersetzt das Dienstprogramm "FPsrvwin.exe": Entdecken Sie die Unterschiede

Das FrontPage-MMC-Snapin ersetzt das Dienstprogramm "Fpsrvwin": Entdecken Sie die Unterschiede

Wenn Sie frühere Versionen der FrontPage-Servererweiterungen eingesetzt haben, haben Sie für ihre Verwaltung möglicherweise das Dienstprogramm Fpsrvwin verwendet. Bei Fpsrvwin handelte es sich um ein Dienstprogramm, mit dem Verwaltungsaufgaben, wie z. B. Installieren, Überprüfen und Korrigieren sowie Entfernen der Servererweiterungen von einem Webserver, durchgeführt werden konnten.

Das FrontPage-MMC-Snapin stellt die am häufigsten verwendeten Funktionen von Fpsrvwin zur Verfügung. Darüber hinaus können Sie die folgenden Aufgaben durchführen:

  • Festlegen von Webeigenschaften, wie z. B. Leistung, E-Mail-Optionen, Skriptberechtigungen und Dokumenterstellungsprotokolle.
  • Erstellen von .
  • Hinzufügen eines Administrators.
  • Konvertieren von Ordnern in Unterwebs und umgekehrt.
  • Löschen von Unterwebs.
  • Öffnen eines in FrontPage (sofern FrontPage auf demselben Computer wie das Web installiert ist).
  • Angeben einer Standard .
  • Protokollieren von Dokumenterstellungsvorgängen.
  • Neuberechnen von Hyperlinks.


Andere Tools, mit denen die FrontPage-Servererweiterungen verwaltet werden können

Beim FrontPage-MMC-Snapin handelt es sich um ein Programm mit einer grafischen Oberfläche, mit dem Sie die FrontPage-Servererweiterungen auf einfache Weise verwalten können. Es ersetzt und verbessert das Dienstprogramm Fpsrvwin, ein Verwaltungsprogramm mit grafischer Oberfläche, das in früheren Versionen von FrontPage enthalten war, erheblich. Das FrontPage-MMC-Snapin kann jedoch nur unter Windows-Betriebssystemen ausgeführt werden. Sie können die Servererweiterungen damit nicht von einem aus verwalten.

Das FrontPage-MMC-Snapin ist jedoch nur eines mehrerer Tools, die zum Verwalten der FrontPage-Servererweiterungen verfügbar sind. Drei weitere Tools, die nahezu über die gleiche Funktionalität wie das FrontPage-MMC-Snapin verfügen, können in Umgebungen eingesetzt werden, in denen das Snapin nicht funktioniert:

  • Beim Dienstprogramm Fpsrvadm handelt es sich um ein Befehlszeilenprogramm, das unter Windows NT und verschiedenen UNIX-Betriebssystemen eingesetzt werden kann. Sie können mit diesem Dienstprogramm durchführen. Fpsrvadm wird beim Installieren der FrontPage-Servererweiterungen installiert. Mit Fpsrvadm können Sie die Servererweiterungen nicht von einem Remotecomputer aus verwalten.
  • Beim Dienstprogramm Fpremadm handelt es sich um ein Befehlszeilenprogramm, mit dem Sie die FrontPage-Servererweiterungen von einem Remotecomputer aus verwalten können. Fpremadm kann jedoch nur unter den Betriebssystemen Windows NT Workstation, Windows NT Server und Windows 95/98, nicht aber unter UNIX-Betriebssystemen, wie z. B. Linux und SunOS, ausgeführt werden. Fpremadm wird beim Installieren der FrontPage-Servererweiterungen installiert.
  • Bei den HTML-Verwaltungsformularen handelt es sich um HTML-Formulare, mit denen Sie die FrontPage-Servererweiterungen von einem Webbrowser aus remote verwalten können.

Weitere Informationen zu diesen Dienstprogrammen finden Sie im Resource-Kit für FrontPage-Servererweiterungen unter http://www.microsoft.com/frontpage/wpp/serk. Wenn die FrontPage-Servererweiterungen auf dem Computer installiert sind, können Sie auch auf das Resource-Kit für FrontPage-Servererweiterungen zugreifen, das standardmäßig in C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\version4.0\serk\nnnn\default.htm installiert wird. Der Ordner \nnnn besitzt einen nummerischen Namen, der von der Sprache abhängt, in der die FrontPage-Servererweiterungen installiert wurden. Bei einer US-englischen Installation beispielsweise lautet der Pfad C:\Programme\Gemeinsame Dateien\Microsoft Shared\Web Server Extensions\version4.0\serk\1033\default.htm.


Verwaltungsaufgaben, die mit dem FrontPage-MMC-Snapin durchgeführt werden können

Sie können mit dem FrontPage-MMC-Snapin die folgenden Aufgaben durchführen:

  • Installieren der FrontPage-Servererweiterungen auf einem Webserver.
  • eines mit den FrontPage-Servererweiterungen.
  • Überprüfen und Korrigieren der FrontPage-Servererweiterungen auf einem .
  • Aktualisieren der FrontPage-Servererweiterungen auf einem Web.
  • Entfernen der FrontPage-Servererweiterungen von einem Web.
  • Löschen eines , das mit den FrontPage-Servererweiterungen erweitert wurde.
  • Konvertieren eines Unterwebs in einen Ordner und umgekehrt.
  • Neuberechnen aller Hyperlinks in einem Web.
  • Hinzufügen eines Administrators.
  • Aktivieren oder Deaktivieren der Dokumenterstellung auf einem Web.
  • Optimieren der .
  • Protokollieren von Dokumenterstellungsvorgängen.
  • Fordern von bei der Dokumenterstellung.
  • Angeben, dass ein Ordner ausführbare oder Programme enthalten kann.
  • Aktivieren der .
  • Festlegen von E-Mail-Optionen.

Die folgenden Aufgaben können Sie nicht mit Hilfe des FrontPage-MMC-Snapins durchführen:

  • Verwalten der FrontPage-Servererweiterungen von einem aus (verwenden Sie stattdessen das Dienstprogramm Fpremadm).
  • Durchführen von (verwenden Sie stattdessen das Dienstprogramm Fpsrvadm).


Finden der benötigten FrontPage-MMC-Snapinkomponenten, um die FrontPage-Servererweiterungen zu verwalten

Mit welchem Menü, Befehl oder Dialogfeld bzw. welcher anderen Komponente des FrontPage-MMC-Snapins können Sie eine bestimmte Aufgabe durchführen, und wo finden Sie die entsprechende Komponente?

Zum Verwalten der FrontPage-Servererweiterungen gibt es drei Hauptkomponenten:

  • Das Menü Neu, in dem Sie Befehle wählen können, um ein neues zu erstellen, einen neuen Administrator hinzuzufügen usw. Dies hängt von dem Element ab, das Sie in der ausgewählt haben.
  • Das Menü Task, in dem Sie Befehle auswählen können, um die FrontPage-Servererweiterungen zu prüfen und zu korrigieren, zu entfernen und zu aktualisieren sowie weitere Aufgaben durchzuführen. Wiederum bestimmt das in der Konsolenstruktur aktivierte Element, welche Befehle im Menü Task angezeigt werden.
  • Auf der Registerkarte Servererweiterungen können Sie die Einstellungen der FrontPage-Servererweiterungen ändern, wie z. B. E-Mail-Optionen und Sicherheitseinstellungen.

Die folgende Tabelle führt die Verwaltungsaufgaben auf, die Sie mithilfe des FrontPage-MMC-Snapins durchführen können, das für die jeweilige Aufgabe verwendete Tool sowie die Stelle des Tools. Die Begriffe in Klammern werden nur angezeigt, falls es sich beim Webserver um Microsoft Internet Information Services (IIS), Version 4.0 oder höher, handelt.

Task | Tool und Stelle
Erweitern eines virtuellen Servers mit den Servererweiterungen (IIS, Version 4.0 oder höher) | Kontextmenü > Task > FrontPage-Servererweiterungen konfigurieren
Erweitern eines virtuellen Servers mit den Servererweiterungen (Nicht-IIS und IIS 3.0) | Kontextmenü > Neu > Web
Erstellen eines Unterwebs | Kontextmenü > Neu > Web (mit Servererweiterungen)
Hinzufügen eines Administrators | Kontextmenü > Neu > Administrator (für Servererweiterungen)
Prüfen und Korrigieren der Servererweiterungen auf einem Web oder Unterweb | Kontextmenü > Task > Servererweiterungen prüfen
Aktualisieren der Servererweiterungen auf einem Web | Kontextmenü > Task > Servererweiterungen aktualisieren
Entfernen der Servererweiterungen von einem Stammweb und seinen Unterwebs | Kontextmenü > Task > Servererweiterungen entfernen
Neuberechnen aller Hyperlinks in einem Web | Kontextmenü > Task > Web neu berechnen
Löschen eines Unterwebs | Kontextmenü > Task > Web mit Servererweiterungen löschen
Konvertieren eines Ordners in ein Unterweb | Kontextmenü > Task > Servererweiterungen konfigurieren
Konvertieren eines Unterwebs in einen Ordner | Kontextmenü > Task > Web mit Servererweiterungen in Ordner konvertieren
Aktivieren oder Deaktivieren der Dokumenterstellung | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Kontrollkästchen Dokumenterstellung aktivieren
Aktivieren der Quelltextkontrolle | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Feld Versionskontrolle
Optimieren der Webleistung | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Feld Leistung
Angeben, welche Skriptsprache standardmäßig erzeugt wird | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Feld Client-Skripts
Festlegen von E-Mail-Optionen | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Einstellungen
Nicht-Übernehmen der Sicherheitseinstellungen eines übergeordneten Webs für ein untergeordnetes Web | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Kontrollkästchen Sicherheitseinstellungen nicht übernehmen
Protokollieren von Dokumenterstellungsvorgängen | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Kontrollkästchen Dokumenterstellungsvorgänge protokollieren
Manuelles Festlegen von Berechtigungen | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Kontrollkästchen Berechtigungen manuell verwalten
Fordern von Secure Sockets Layer (SSL) für die Dokumenterstellung | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Kontrollkästchen Dokumenterstellung nur mit SSL zulassen
Angeben, dass ein Ordner ausführbare Skripts oder Programme enthalten kann oder nicht | Kontextmenü > Eigenschaften > Registerkarte Servererweiterungen > Kontrollkästchen Uploaden von Programmen durch Autoren zulassen


Das Modell für Berechtigungen in FrontPage

Zum Verwalten des Zugriffs auf auf einem Webserver stellt FrontPage ein einfaches rollenbasiertes Modell für sowie nützliche Verwaltungstools zum Festlegen von Berechtigungen zur Verfügung. Das rollenbasierte Modell besagt einfach, dass die einem Benutzer erteilten Berechtigungen von der Rolle des Benutzer abhängen (ein Benutzer kann eine Person, eine Gruppe oder ein Computer sein).

Für jedes auf einem Webserver können Sie die Berechtigungen für Benutzer anhand der drei folgenden Rollen festlegen:

  • besucher, denen Sie Lesezugriff gewähren. Diese Berechtigung ermöglicht das Anzeigen und Verwenden eines Webs mit FrontPage-Servererweiterungen, nachdem es auf einem Webserver veröffentlicht wurde.
  • Autoren, denen Sie Schreibzugriff gewähren. Diese Berechtigung ermöglicht das Öffnen und das Ändern der Inhalte eines Webs mit FrontPage-Servererweiterungen.
  • Administratoren, denen Sie Verwaltungszugriff gewähren. Diese Berechtigung ermöglicht das Hinzufügen, Aktualisieren oder Entfernen der FrontPage-Servererweiterungen von einem Web mit FrontPage-Servererweiterungen, das Erstellen und Löschen von , das Protokollieren von Dokumenterstellungsvorgängen, das Festlegen von Berechtigungen für andere Benutzer sowie das Durchführen weiterer Verwaltungsaufgaben.

Die Berechtigungen für ein Web mit FrontPage-Servererweiterungen sind hierarchisch gegliedert: Ein Benutzer mit Verwaltungszugriff verfügt über Schreib- und Lesezugriff. Ein Benutzer mit Schreibzugriff verfügt über Lesezugriff.

Die für ein Web festgelegten Berechtigungen werden standardmäßig von allen Unterwebs darunter übernommen. Sie können jedoch für ein Unterweb eindeutige Berechtigungen festlegen, die die vom übergeordneten Web übernommenen Berechtigungen überschreiben. Auf diese Weise können Sie jedem Benutzer oder jeder Gruppe verschiedene Zugriffsstufen für ein Unterweb zuweisen. Sie können beispielsweise einem Benutzer Schreibzugriff auf ein Unterweb, jedoch nur Lesezugriff für ein anderes Unterweb erteilen.

Für welche Benutzer können Sie Berechtigungen festlegen? Die Antwort hängt von dem Webserver ab, mit dem Sie arbeiten. Microsoft Internet Information Services (IIS) verwendet die Benutzerkonten von der Windows NT-Kontenliste. Sie können Berechtigungen nur für Benutzer in dieser Liste festlegen und keine neuen Benutzerkonten erstellen. Bei anderen Webservern wird die Liste der Benutzer jedoch vom Webserver verwaltet, und Sie können neue Benutzerkonten erstellen.

Sie können die Berechtigungen für ein Web in FrontPage mit Hilfe der Dienstprogramme für die FrontPage-Servererweiterungen, wie z. B. Fpsrvadm, sowie im Menü Extras mit dem Befehl Berechtigungen festlegen.


Funktionsweise des FrontPage-MMC-Snapins bei anderen Webservern

Wenn Sie sowohl mit Microsoft Internet Information Services (IIS) als auch anderen Webservern, wie z. B. WebSite oder Netscape, arbeiten, stellen Sie möglicherweise fest, dass das FrontPage-MMC-Snapin bei IIS, Version 4.0 oder höher, anders funktioniert als bei anderen Webservern, wie z. B. IIS 3.0.

IIS, Version 4.0 oder höher, verfügt über ein Snapin, das sich in Microsoft Management Console (MMC) einklinkt. Das FrontPage-MMC-Snapin ist so aufgebaut, dass es sich in das Snapin von IIS, Version 4.0 oder höher, einklinkt. Wenn IIS, Version 4.0 oder höher, auf einem Computer installiert ist, wird die Funktionalität des FrontPage-Snapins daher vollständig in die von IIS integriert.

Wenn Sie zuvor bereits mit dem IIS-MMC-Snapin gearbeitet haben, werden Sie feststellen, dass einige Befehle zum Menü Aktion und zu den Kontextmenüs und die Registerkarte Servererweiterungen zum Dialogfeld Eigenschaften hinzugefügt wurden. Diese neue Funktionalität stammt vom FrontPage-MMC-Snapin. Bei überlappender Funktionalität wird der IIS-Befehl angezeigt, nicht der Befehl des FrontPage-Snapins. In der führt IIS alle IIS- auf, sowohl als auch andere Websites.

Ist das FrontPage-MMC-Snapin zusammen mit einem anderen Webserver als IIS, Version 4.0 oder höher, installiert, wird seine Funktionalität nicht in die des Webservers integriert. Tatsächlich kann es sein, dass der Webserver nicht einmal über ein MMC-Snapin verfügt, das die Funktionalität der Konsole erweitert. In einem solchen Fall führt die Konsolenstruktur lediglich Webs mit FrontPage-Servererweiterungen auf, d. h. nicht alle Websites auf dem Computer werden aufgelistet.

Manchmal sind sowohl IIS, Version 4.0 oder höher, als auch andere Webserver auf demselben Computer installiert. In diesem Fall wird für jeden Webserver ein Element auf der obersten Ebene angezeigt, und die jeweiligen Websites werden darunter aufgeführt. Wenn Sie ein markieren, das sich auf einem Webserver von IIS, Version 4.0 oder höher, befindet, und dann das Kontextmenü anzeigen, werden die Befehle des IIS-Snapins zusammen mit den Befehlen des FrontPage-Snapins angezeigt. Wenn Sie ein Web markieren, das sich auf dem Nicht-IIS-Webserver befindet, und dann das Kontextmenü anzeigen, stammen die Befehle zum Verwalten der FrontPage-Servererweiterungen ausschließlich vom FrontPage-MMC-Snapin.


Erweitern eines virtuellen Servers mit den FrontPage-Servererweiterungen

Nach dem Erstellen eines können Sie ihn mit den FrontPage-Servererweiterungen und den virtuellen Server somit in ein umwandeln. Bevor Sie einen virtuellen Server erweitern können, müssen die Servererweiterungen bereits auf dem Servercomputer installiert sein.

So erweitern Sie einen virtuellen Server mit den FrontPage-Servererweiterungen

  1. Klicken Sie in der mit der rechten Maustaste auf den virtuellen Server, der erweitert werden soll.
  2. Klicken Sie im Kontextmenü auf Task und dann auf FrontPage-Servererweiterungen konfigurieren.

Falls es sich bei dem Webserver nicht um IIS, Version 4.0 oder höher, handelt, klicken Sie im Kontextmenü auf Neu und dann auf Web.

  3. Folgen Sie den Schritten im Konfigurationsassistenten für Servererweiterungen.

Anmerkung

Sie müssen einen virtuellen Server erweitern, d. h. in ein Stammweb umwandeln, bevor Sie darunter erstellen können.


Erstellen eines Unterwebs

Bei einem Unterweb handelt es sich um einen Ordner des oder eines anderen Unterwebs, das ein vollständiges bildet. Es stellt die logische Unterteilung des Inhalts einer gesamten dar.

Mit Hilfe eines Unterwebs können Sie auf einfache Weise getrennte für die Verwaltung, für die Dokumenterstellung sowie für das Durchsuchen festlegen, den Webinhalt in logische Teilbereiche aufteilen, um die Leistung zu steigern, den Seiten jedes einzelnen Unterwebs ein anderes Aussehen zuweisen und Hyperlinks verwalten.

Sie können ein Unterweb nur in einem Stammweb, einem Unterweb oder einem Ordner unter dem Stammweb bzw. Unterweb erstellen. Bei Erstellen eines Unterwebs Sie es gleichzeitig mit den FrontPage-Servererweiterungen. Das System erstellt für das Unterweb automatisch einen Ordner.

So erstellen Sie ein Unterweb und erweitern es mit den FrontPage-Servererweiterungen

  1. Klicken Sie in der mit der rechten Maustaste auf das (oder den Ordner), unter dem Sie ein Unterweb erstellen möchten.
  2. Klicken Sie im Kontextmenü auf Neu und dann auf Web mit Servererweiterungen.

Falls es sich bei dem Webserver nicht um IIS, Version 4.0 oder höher, handelt, klicken Sie im Kontextmenü auf Neu und dann auf Web.

  3. Folgen Sie den Schritten im Assistenten für neues Unterweb.


Hinzufügen eines Administrators

Falls Sie das Kennwort vergessen haben oder eine andere Person ein Web verwalten können soll, können Sie einen Administrator hinzufügen.

So fügen Sie einen Administrator hinzu:

  1. Klicken Sie in der mit der rechten Maustaste auf das , zu dem Sie einen Administrator hinzufügen möchten.
  2. Klicken Sie im Kontextmenü auf Neu und dann auf Administrator für Servererweiterungen.

Falls es sich bei dem Webserver nicht um IIS, Version 4.0 oder höher, handelt, klicken Sie im Kontextmenü auf Neu und dann auf Administrator.

  3. Geben Sie im Feld Benutzername ein Windows NT-Konto ein, das als Administrator zum Web hinzugefügt werden soll.

Falls es sich bei dem Webserver nicht um IIS, Version 4.0 oder höher, handelt, geben Sie im Feld Benutzername einen Benutzernamen und im Feld Kennwort und im Feld Kennwort bestätigen dasselbe Kennwort ein.


Entfernen der FrontPage-Servererweiterungen von einem Stammweb und seinen Unterwebs

Bisweilen können Sie oder der Autor eines entscheiden, dass die FrontPage-Servererweiterungen für ein Web nicht mehr erforderlich sind. In diesem Fall können Sie die Servererweiterungen vom entfernen, wobei die Servererweiterungen auch von allen darunter entfernt werden.

Beim Entfernen der Servererweiterungen funktionieren alle Funktionen im Web, die von den FrontPage-Servererweiterungen unterstützt werden, wie z. B. Zugriffszähler und Behandlungsroutinen für E-Mail-Formulare, nicht mehr. Der Webinhalt bleibt erhalten. Lediglich die Servererweiterungen werden entfernt.

So entfernen Sie die Servererweiterungen von einem Stammweb und seinen Unterwebs

  1. Klicken Sie in der mit der rechten Maustaste auf das Web, von dem die Servererweiterungen entfernt werden sollen.
  2. Klicken Sie im Kontextmenü auf Task und dann auf Servererweiterungen entfernen.

Standardmäßig werden Dateien, die Informationen über die Webstruktur, Designs usw. enthalten, nicht gelöscht, so dass Sie das Web genauso neu erstellen können, wenn Sie sich entschließen, es zu einem späteren Zeitpunkt erneut zu erweitern. Wenn Sie jedoch die FrontPage-Servererweiterungen für dieses Web nie mehr benötigen, deaktivieren Sie das Kontrollkästchen Meta-Information für Upgrade oder Reinstallation der FrontPage-Servererweiterungen zu späteren Zeitpunkt behalten.

  3. Klicken Sie auf OK.


Prüfen und Korrigieren der FrontPage-Servererweiterungen auf einem Web oder einem Unterweb

Manchmal ist der Autor eines möglicherweise nicht in der Lage, Webinhalte zu uploaden, das Web direkt auf dem Servercomputer zu ändern oder andere Dokumenterstellungsfunktionen durchzuführen, die von den FrontPage-Servererweiterungen unterstützt werden. Die Ursache des Problems kann vom unbeabsichtigten Löschen oder Umbenennen wesentlicher Dateien bis hin zu Beschädigungen der reichen. Zum Beheben vieler Probleme während der Dokumenterstellung können Sie den Befehl Servererweiterungen prüfen verwenden, der die folgenden Aufgaben durchführt:

  • Überprüfen der für den Lesezugriff.
  • Überprüfen, dass Schreib-/Lesezugriff für Service.cnf und Service.lck besteht.
  • Aktualisieren von Postinfo.html und _vti_inf.htm.
  • Überprüfen, ob _vti_pvt, _vti_log und _vti_bin installiert sind und _vti_bin ausführbar ist.
  • Feststellen, ob die Einstellungen des Stammordners und der Metabasis eines richtig eingestellt sind und dem aktuellen Stand entsprechen.
  • Überprüfen, dass das anonyme IUSR-Konto über keinen Schreibzugriff verfügt.
  • Warnen, falls die Ausführung auf einem FAT-Dateisystem erfolgt, was zur Folge hat, dass eine Websicherheit in keinerlei Hinsicht möglich ist (falls IIS ausgeführt wird).

So überprüfen und korrigieren Sie die FrontPage-Servererweiterungen

  1. Klicken Sie in der mit der rechten Maustaste auf das Web, für das die Servererweiterungen überprüft und korrigiert werden sollen.

Das betreffende Web sowie alle darunter werden überprüft und korrigiert.

  2. Klicken Sie im Kontextmenü auf Task und dann auf Servererweiterungen prüfen.

Das Fenster Web überprüfen zeigt für jedes überprüfte Web ein Statusprotokoll an.


Aktualisieren der FrontPage-Servererweiterungen auf einem Web.

Von Zeit zu Zeit wird eine neue Version der FrontPage-Servererweiterungen zur Verfügung gestellt. Die neue Version enthält eine verbesserte Unterstützung für Webautoren und -administratoren oder Korrekturen vorhandener Unterstützungsfeatures und unterstützt alle vorhandenen Funktionen in FrontPage, wie z. B. Zugriffszähler.

Um die Vorteile dieser neuen Unterstützung zu nutzen, müssen Sie zunächst die neueste Version der Servererweiterungen auf dem Servercomputer installieren und dann das auf diese Version aktualisieren. Sie können die Servererweiterungen nur auf aktualisieren. Beim Aktualisieren eine Stammwebs werden jedoch auch alle aktualisiert.

So führen Sie eine Aktualisierung auf die neueste Version der FrontPage-Servererweiterungen durch

  1. Klicken Sie in der mit der rechten Maustaste auf das Stammweb, auf dem die Servererweiterungen aktualisiert werden sollen.
  2. Klicken Sie im Kontextmenü auf Task und dann auf Servererweiterungen aktualisieren.

Anmerkungen

Der Befehl Servererweiterungen aktualisieren wird nur angezeigt, wenn eine neuere Version der Servererweiterungen zur Verfügung steht.

Um die FrontPage-Servererweiterungen für alle Stammwebs auf einem Computer zu aktualisieren, klicken Sie in der Konsolenstruktur auf Arbeitsplatz.


Löschen eines Webs mit FrontPage-Servererweiterungen

Ein kann veralten, selten verwendet oder aus wie auch immer gearteten Gründen nicht mehr von Nutzen sein. Beispielsweise wurde ein Projekt, dessen Informationen in einem Firmenintranet veröffentlicht wurden, beendet oder neu organisiert. Oder ein Abonnent, der eine auf dem Webserver eines Internetdienstanbieters veröffentlichte, hat den Dienst gekündigt. In diesen und anderen Fällen müssen Sie unter Umständen das Unterweb löschen.

Beim Löschen eines Unterwebs werden alle Inhalte, Dateien, Ordner und geschachtelten Unterwebs sowie die FrontPage-Servererweiterungen gelöscht. Das Löschen eines Unterwebs kann nicht rückgängig gemacht werden.

So löschen Sie ein Unterweb

  1. Klicken Sie in der mit der rechten Maustaste auf das Unterweb, das gelöscht werden soll.
  2. Klicken Sie im Kontextmenü auf Task und dann auf Web mit Servererweiterungen löschen.
  3. Klicken Sie auf OK.

Anmerkung

Falls Sie über keine Berechtigung verfügen, ein Unterweb zu löschen, das sich unter dem zu löschenden Unterweb befindet, wird das geschachtelte Unterweb nicht gelöscht.


Konvertieren eines Ordners in einem Web in ein Unterweb

Wenn Sie entscheiden, dass ein Ordner über genügend Webinhalt verfügt (wie z. B. Webseiten und Grafiken), um als eigenständige zu fungieren, können Sie den betreffenden Ordner auf einfache Weise in ein konvertieren. Dies stellt eine der Möglichkeiten dar, ein zu erstellen.

So konvertieren Sie einen Ordner in ein Unterweb

  1. Klicken Sie in der mit der rechten Maustaste auf den Ordner, den Sie in ein Unterweb mit FrontPage-Servererweiterungen konvertieren möchten.
  2. Klicken Sie im Kontextmenü auf Task und dann auf Servererweiterungen konfigurieren.

Falls es sich bei dem Webserver nicht um IIS, Version 4.0 oder höher, handelt, klicken Sie im Kontextmenü auf Task und dann auf In Web konvertieren.


Konvertieren eines Unterwebs in einen Ordner

Unter Umständen können Sie sich entscheiden, dass ein nicht mehr benötigt wird, Sie jedoch seinen Inhalt behalten möchten. In diesem Fall können Sie ein in einen Ordner seines konvertieren. Beim Konvertieren eines Unterwebs in einen Ordner werden die FrontPage-Servererweiterungen von dem Unterweb entfernt, das Unterweb in einen regulären Ordner des übergeordneten Webs konvertiert und alle unter dem konvertierten Unterweb geschachtelten Unterwebs mit den entsprechenden übergeordneten Webs verknüpft.

Die Unterwebs unter dem konvertierten Unterweb übernehmen unter Umständen verschiedene Designs und Einstellungen für die . Falls sich unter dem konvertierten Unterweb keine Unterwebs befinden, verlieren die Seiten innerhalb des konvertierten Unterwebs möglicherweise einige Webeigenschaften.

So konvertieren Sie ein Unterweb in einen Ordner

  1. Klicken Sie in der mit der rechten Maustaste auf das Unterweb mit FrontPage-Servererweiterungen, das Sie in einen Ordner konvertieren möchten.
  2. Klicken Sie im Kontextmenü auf Task und dann auf Web mit Servererweiterungen in Ordner konvertieren.

Falls es sich bei dem Webserver nicht um IIS, Version 4.0 oder höher, handelt, klicken Sie im Kontextmenü auf Task und dann auf In Ordner konvertieren.


Öffnen eines Webs mit Hilfe von FrontPage

Als Administrator müssen Sie möglicherweise manchmal das Design, den Text, die Grafiken oder andere Inhalte eines oder ändern. Wenn FrontPage auf demselben Server installiert ist wie das oder das Unterweb, können Sie das Web direkt von der aus öffnen und seinen Inhalt ändern oder in FrontPage andere Aktionen durchführen. Andernfalls können Sie ein Web nicht von der Konsole aus öffnen.

So öffnen Sie ein Web mit Hilfe von FrontPage

  1. Klicken Sie in der mit der rechten Maustaste auf das Web, das Sie in FrontPage öffnen möchten.
  2. Klicken Sie im Kontextmenü auf Task und dann auf Mit FrontPage öffnen.
  3. Ändern Sie in FrontPage den Webinhalt, und speichern Sie die Änderungen.

Anmerkung

Falls FrontPage nicht auf dem Server installiert ist, wird der Befehl Mit FrontPage öffnen nicht angezeigt.


Neuberechnen aller Hyperlinks in einem Web

Alle Änderungen, die Sie an der Struktur eines vornehmen, können die Hyperlinks zwischen den verschiedenen Pfaden des jeweiligen Webs ändern. Wenn beispielsweise eine Seite hinzugefügt, umbenannt oder von einem Ordner in einen anderen verschoben wird, müssen die Hyperlinks zu der betreffenden Seite von allen anderen Seiten und Dokumenten im Web aktualisiert oder neu berechnet werden, um die-logischen Verknüpfungen wiederherzustellen. FrontPage berechnet Hyperlinks automatisch neu. Wenn Sie jedoch eine Neuberechnung „erzwingen“ möchten, können Sie dies tun.

So berechnen Sie alle Hyperlinks in einem Web neu

  1. Klicken Sie in der mit der rechten Maustaste auf das Web, dessen Hyperlinks neu berechnet werden sollen.
  2. Klicken Sie im Kontextmenü auf Task und dann auf die Registerkarte Web neu berechnen.


Angeben, welche Skriptsprache standardmäßig erzeugt wird

Als Reaktion auf bestimmte Dokumenterstellungsvorgänge erzeugen die FrontPage-Servererweiterungen clientseitige Skripts. Standardmäßig erzeugen die Servererweiterungen diese Skripts in der JavaScript. JavaScript wird von den beiden am weitesten verbreiteten Webbrowsern, Netscape Navigator und Microsoft Internet Explorer, sowie von anderen Webbrowsern erkannt. Darüber hinaus können Sie diese Skripts in VBScript erstellen lassen, das jedoch nicht von Netscape Navigator erkannt wird. VBScript kann jedoch die bevorzugte Wahl darstellen, wenn Sie beispielsweise ein Firmenintranet verwalten, das ausschließlich mit Internet Explorer arbeitet, bzw. VBScript die bevorzugte Skriptsprache bei den Programmierern der Firma darstellt.

So geben Sie an, welche Skriptsprache standardmäßig erzeugt wird

  1. Klicken Sie in der mit der rechten Maustaste auf das , für das Sie die standardmäßig erzeugte Skriptsprache angeben möchten.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Wählen Sie im Feld Client-Skripts eine Skriptsprache aus.


Manuelles Festlegen von Berechtigungen

Die rollenbasierten , die Sie für jedes für Administratoren, Autoren und besucher mit Hilfe von FrontPage festlegen und verwalten können, entsprechen nicht immer den jeweiligen Anforderungen. Unter Umständen möchten Sie beispielsweise die Berechtigungen für Dateien und Ordner festlegen. Sie können benutzerdefinierte Berechtigungen manuell festlegen, indem Sie die Berechtigungen direkt in den festlegen. Weitere Informationen über das Festlegen benutzerdefinierter Berechtigungen finden Sie im Resource-Kit für Servererweiterungen unter http://www.microsoft.com/frontpage/wpp/serk.

Wenn Sie FrontPage zum Verwalten von Berechtigungen verwenden, werden jedoch alle festgelegten benutzerdefinierten Berechtigungen geändert, indem die ACLs zurückgesetzt werden. Um zu gewährleisten, dass weder Sie noch eine andere Person benutzerdefinierte Berechtigungen unbeabsichtigt überschreibt, können Sie in FrontPage Berechtigungen deaktivieren.

So legen Sie Berechtigungen manuell fest

  1. Klicken Sie in der mit der rechten Maustaste auf das , für das die Berechtigungen manuell festgelegt werden sollen.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Stellen Sie sicher, dass das Kontrollkästchen Berechtigungen manuell verwalten aktiviert ist.


Aktivieren oder Deaktivieren der Dokumenterstellung in einem Web

Aktivieren oder Deaktivieren der Dokumenterstellung in einem Stammweb und in seinen Unterwebs

, die erstellt oder häufig aktualisiert werden, müssen für ihre Autoren erreichbar sein. Einige Webs können jedoch, nachdem sie fertig gestellt wurden, wesentliche oder permanente Informationen enthalten, die nicht verändert werden sollen. Oder Sie möchten andere Personen daran hindern, ein Web zu ändern, wenn es an eine neue Stelle verschoben wird oder andere Änderungen vorgenommen werden. Um die Informationen in einem Web zu schützen, können Sie die Dokumenterstellung auf dem Web deaktivieren, was zur Folge hat, dass Benutzer Webinhalte weder hinzufügen noch ändern können.

So aktivieren oder deaktivieren Sie die Dokumenterstellung in einem Stammweb und in seinen Unterwebs

  1. Klicken Sie in der mit der rechten Maustaste auf das Stammweb, für das die Dokumenterstellung aktiviert oder deaktiviert werden soll.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Zum Aktivieren der Dokumenterstellung muss das Kontrollkästchen Dokumenterstellung aktivieren aktiviert sein.

Zum Deaktivieren der Dokumenterstellung muss das Kontrollkästchen Dokumenterstellung aktivieren deaktiviert sein.


Angeben, dass ein Ordner ausführbare Skripts oder Programme enthalten kann oder nicht

Angeben, dass Ordner ausführbare Skripts oder Programme enthalten können oder nicht

Wenn ein Webautor ein - oder eine Active Server Page (ASP) in eine einschließen möchte, müssen Sie sicherstellen können, dass der Autor kein fehlerhaftes Programm oder - viel gravierender - einen Virus unwiderruflich auf den Webserver uploadet. Sie können die Risiken im Zusammenhang mit Programmfehlern und Viren vermeiden, indem Sie verhindern, dass ein Autor Skripts und Programme in einen Ordner uploadet, der Bestandteil eines ist.

So geben Sie an, dass Ordner ausführbare Skripts oder Programme enthalten können oder nicht

  1. Klicken Sie in der mit der rechten Maustaste auf das , für das Sie Ordner als ausführbar markieren möchten.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Stellen Sie sicher, dass das Kontrollkästchen Uploaden von Programmen durch Autoren zulassen aktiviert ist.


Protokollieren von Dokumenterstellungsvorgängen

Benutzer mit der Berechtigung, den Inhalt eines zu ändern, können Text, Grafiken, Hyperlinks, die Struktur usw. ändern. Um zu verfolgen, von wem Änderungen an einem Web vorgenommen und welche Dateien geändert wurden, können Sie Dokumenterstellungsvorgänge in einem und allen seinen protokollieren. Das System zeichnet dann die folgenden Daten auf: Uhrzeit, zu der die Aktion eines Autors durchgeführt wurde, Benutzername des Autors, Webname, Remote-Host und die Daten der Operation, und speichert diese Informationen in einer Protokolldatei mit dem Namen _vti_log/Author.log im Stammweb. Falls die Sicherheit durchbrochen wurde, können Sie diese Protokolldatei analysieren und feststellen, welche Dokumenterstellungsaktivitäten auf dem Web erfolgten.

So protokollieren Sie Dokumenterstellungsvorgänge

  1. Klicken Sie in der mit der rechten Maustaste auf das Stammweb, für das Dokumenterstellungsvorgänge protokolliert werden sollen.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Stellen Sie sicher, dass das Kontrollkästchen Dokumenterstellungsvorgänge protokollieren aktiviert ist.


Fordern von Secure Sockets Layer (SSL) für die Dokumenterstellung

Webinformationen sind besonders verwundbar gegenüber Störungen, wenn sie „unterwegs“ sind, d. h. wenn sie von einem Teil des zu einem anderen übertragen werden. Sie können die Sicherheit der Übertragung gegen potentielle Eindringlinge erheblich steigern, wenn Sie für die Übertragung von Informationen zwischen FrontPage, Webbrowsern und Webservern das Standardprotokoll fordern.

So fordern Sie SSL für die Dokumenterstellung

  1. Klicken Sie in der mit der rechten Maustaste auf das , für das Sie den Einsatz von SSL fordern möchten.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Stellen Sie sicher, dass das Kontrollkästchen Dokumenterstellung nur mit SSL zulassen aktiviert ist.

Anmerkung

Wenn Sie für die Dokumenterstellung SSL fordern, erhalten Autoren, die versuchen, auf dem Web zu arbeiten, eine Meldung, dass sie SSL verwenden müssen. Die Autoren können dies in FrontPage auswählen.


Optimieren der Webleistung

Die Geschwindigkeit, mit der ein auf Anforderungen von einem FrontPage-Client reagiert, hängt wesentlich von der Größe des Webs ab, insbesondere von der darin enthaltenen Anzahl an Seiten und weiteren Dateien. Sie können die Reaktionszeit eines Webs verkürzen, indem Sie es „optimieren“. Beim Optimieren eines Webs reservieren die FrontPage-Servererweiterungen abhängig von der Anzahl der Webseiten einen bestimmten Cacheumfang für das Web. Sie können ein Web beispielsweise für weniger als 100 oder mehr als 1000 Seiten optimieren. Darüber hinaus können Sie die die Cachegröße und die Größe des Indexes für Volltextsuchen anpassen.

So optimieren Sie die Webleistung

  1. Klicken Sie in der mit der rechten Maustaste auf das Web, dessen Leistung optimiert werden soll.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Wählen Sie im Feld Leistung den Seitenbereich, der am ehesten der tatsächlichen Anzahl an Seiten in dem Web, das optimiert wird, entspricht.
  4. Um ein Web individuell zu optimieren, klicken Sie auf Benutzerdefinierte Einstellungen verwenden, und geben Sie dann die gewünschte Größe für den Cache und den Index für Volltextsuchen an.


Aktivieren der Quellcodeverwaltung

Wenn mehrere Personen den Webinhalt ändern, können Sie mithilfe der Quellcodeverwaltung feststellen, wer derzeit ein bestimmtes Webdokument ändert, alle Änderungen feststellen, verhindern, dass die Änderungen eines Autors Änderungen eines anderen Autors löschen, und gegebenenfalls zu einer vorherigen Version eines Dokuments zurückkehren. Um die Quellcodeverwaltung für ein bestimmtes zur Verfügung zu stellen, können Sie die integrierte Quellcodeverwaltung von FrontPage oder ein externes Programm zur Quellcodeverwaltung, das FrontPage unterstützt, wie z. B. Microsoft Visual SourceSafe, verwenden.

Die integrierte Quellcodeverwaltung ist in den FrontPage-Servererweiterungen enthalten. Sie können damit ein Web ein- und auschecken und zur letzten gespeicherten Version eines Webs zurückkehren. Bei Visual SourceSafe und anderen Programmen zur Quellcodeverwaltung handelt es sich um Programme, die Sie getrennt erwerben und auf dem Computer installieren müssen. In der Regel verfügen externe Programme zur Quellcodeverwaltung über den vollständigen Funktionsumfang der integrierten Quellcodeverwaltung, verfolgen zusätzlich Änderungen und können zu einer beliebigen Version mehrerer früherer Versionen eines Webs zurückkehren.

So aktivieren Sie die Quellcodeverwaltung

  1. Klicken Sie in der mit der rechten Maustaste auf das Web, für das die Quellcodeverwaltung aktiviert werden soll.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Aktivieren Sie im Feld Versionskontrolle entweder Externe verwenden oder Integrierte verwenden.

Wenn Sie Externe verwenden ausgewählt haben, geben Sie den Namen des Visual SourceSafe-Projekts oder des anderen Projekts ein, das verwendet werden soll.

Anmerkung

Sie können Visual SourceSafe nur dann mit FrontPage verwenden, wenn die Option Integration von SourceSafe ermöglichen in Visual SourceSafe aktiviert ist. Dabei handelt es sich um eine Option der benutzerdefinierten Installation, die Sie beim Installieren von Visual SourceSafe auswählen müssen.


Festlegen von E-Mail-Optionen

Bei einigen Features ist es erforderlich, dass an die Sitebesucher, die ein Web durchsuchen, E-Mail-Nachrichten gesendet werden. Ein Beispiel für ein solches Feature ist die Behandlungsroutine für E-Mail-Formulare. Damit diese Features E-Mail-Nachrichten senden können, müssen Sie die E-Mail-Adresse des Webservers, eine Kontaktadresse, einen SMTP-Host, ein E-Mail-Codierungsschema und einen E-Mail-Zeichensatz angeben.

So legen Sie E-Mail-Optionen fest

  1. Klicken Sie in der mit der rechten Maustaste auf das , für das Sie die E-Mail-Optionen festlegen möchten.
  2. Klicken Sie im Kontextmenü auf Eigenschaften und dann auf die Registerkarte Servererweiterungen.
  3. Klicken Sie unter Optionen auf Einstellungen.
  4. Geben Sie die gewünschten Einstellungen ein.


Onlinesupport vom Microsoft Software Service

Erhalten Sie die aktuellsten Antworten auf technische Fragen über das Internet

Wenn Sie eine technische Frage haben und die Antwort nicht in der Windows NT-Hilfedatei finden können, gehen Sie zu Support Online. Wählen Sie einfach Ihr Produkt aus, geben Sie Ihre Frage ein, und die Site erledigt den Rest der Arbeit für Sie. Von technischen Artikeln in der Microsoft Knowledge Base bis zum Assistenten für Problembehandlung und downloadbaren Dateien sammelt Support Online die speziellen Ressourcen, die Ihnen wahrscheinlich beim Finden der Antwort auf Ihre Frage helfen.

Zum Start Ihrer Suche gehen Sie zu http://support.microsoft.com/support/.


E-Mail-Einstellungen

In diesem Dialogfeld geben Sie an, wie E-Mail-Nachrichten von einem Web aus gesendet werden, das E-Mail-basierte Features umfasst, wie z. B. eine Formularbehandlungsroutine.

E-Mail-Adresse des Webservers

Geben Sie die E-Mail-Adresse ein, die in der Zeile Von der E-Mail-Nachrichten angezeigt werden soll, die von bestimmten Komponenten in FrontPage, wie z. B. Ergebnisformularen, gesendet werden.

Kontaktadresse

Geben Sie die E-Mail-Adresse ein, an die sich Benutzer bei Problemen wenden können. Die eingegebene Adresse wird in Fehlermeldungen angezeigt, die bei einigen auftretenden Problemen den Benutzern von FrontPage angezeigt werden.

SMTP-Mailserver

Geben Sie den Namen des SMTP-Hosts ein, der die Nachrichten vom oder zum Web leitet.

E-Mail-Codierung

Klicken Sie auf das E-Mail-Codierungsschema, das für die Nachrichten verwendet werden soll. Die Standardeinstellung ist die 8-Bit-Codierung, die am häufigsten verwendet wird. Sie können das Codierungsschema wechseln, wenn Sie wissen, dass ein E-Mail-Empfänger ein anderes Codierungsschema verwendet und die Nachrichten nicht lesen kann.

Zeichensatz

Klicken Sie auf den Namen des Zeichensatzes, der in den E-Mail-Nachrichten verwendet werden soll. Jeder Zeichensatz bildet das Alphabet einer Sprache.


Leistung

In diesem Dialogfeld geben Sie die Größe des Caches für alle Arten von Informationen an, die in einem Web häufig verwendet werden. Wenn Sie die Cachegrößen für das betreffende Web geeignet einstellen, können Sie die Reaktionszeit des Webs auf Benutzeraktivitäten verringern.

Cache für Dokumente im Speicher

Geben Sie die maximale Anzahl der Dokumente ein, deren Eigenschafteninformationen, wie z. B. Hyperlinkschemas und Webparameter, aktiv im Speicher gespeichert werden sollen. Diese Zahl stellt die letzten <angegebene Zahl> Dokumente dar, mit denen gearbeitet wurde. Wenn Sie beispielsweise 4096 angeben, werden die Eigenschafteninformationen für das 4097. Dokument aus dem Speicher entfernt.

Cache für eingeschlossene Dateien

Geben Sie die Anzahl der Dateien, die in andere Dateien eingeschlossen werden, ein, die sich im Speicher befinden sollen. Beispielsweise gibt es unter Umständen Dateien mit Kopf- und Fußzeilen sowie mit Informationen zum Copyright, die in einigen oder allen Webseiten einer Website eingeschlossen werden sollen.

Cache für Bilddateien

Geben Sie die Anzahl der Bilddateien im Speicher ein, die von den FrontPage-Servererweiterungen verwendet werden können, um in Webseiten übereinander liegende Bilder zu erstellen. Eine Datei könnte beispielsweise aus einem Hintergrund, eine andere aus einer Navigationsschaltfläche bestehen. Die Servererweiterungen können ein Bild zusammensetzen, indem der Hintergrund zu einer Webseite hinzugefügt und anschließend mit dem Bild für die Navigationsschaltfläche überlagert wird. Das Bild kann in kürzerer Zeit zusammengesetzt werden, wenn sich die Komponentendateien im Cache befinden.

Indexgröße für Volltextsuche

Geben Sie die maximale Größe des Speicherplatzes an, der zum Speichern des Volltextsuchindex verwendet werden kann. Wird dieser Umfang erreicht, können keine weiteren Seiten der Website indiziert werden (bis Sie diese Zahl erhöhen).

Maximalgröße von Dokumenten im Cache

Geben Sie die maximale Größe eines Dokuments ein, das im Speicher gespeichert werden kann. Diese Grenzgröße gilt für alle eingeschlossenen Dateien, Bilddateien und anderen Dateien, die im Cache gespeichert werden können.


Standardeigenschaften für Webs - Eigenschaftenseite "Veröffentlichen"

Standardeigenschaften für Websites - Eigenschaftenseite "Servererweiterungen"

Auf dieser Eigenschaftenseite legen Sie für ein Web mit FrontPage-Servererweiterungen die Steuerelemente zum Veröffentlichen fest.

Dokumenterstellung aktivieren (nur Stammweb)

Ermöglicht Autoren mit Hilfe von FrontPage auf das ausgewählte Web zuzugreifen und seinen Inhalt zu ändern. Deaktivieren Sie das Kontrollkästchen Dokumenterstellung aktivieren, um zu verhindern, dass jemand auf das ausgewählte Web zugreift und seinen Inhalt ändert.

Versionskontrolle

Klicken Sie auf die Methode für die Quelltextkontrolle, die Sie verwenden möchten, um zu verfolgen, wer den Inhalt eines Webs ändert, und alle Änderungen zu kennzeichnen sowie zu verhindern, dass die Änderungen eines Autor die Änderungen eines anderen löschen. Sie können entweder die integrierte Quelltextkontrolle oder ein externes Programm, wie z. B. Microsoft Visual SourceSafe, auswählen, das mehr Features zu Quelltextkontrolle bietet.

Leistung

Klicken Sie auf den Seitenbereich, der am ehesten der tatsächlichen Anzahl der Seiten in dem ausgewählten Web entspricht. Die FrontPage-Servererweiterungen reservieren abhängig vom gewählten Seitenbereich einen bestimmten Cacheumfang.

Client-Skripts

Klicken Sie auf die Skriptsprache, entweder JScript oder VBScript, die von den FrontPage-Servererweiterungen automatisch auf Seiten erzeugt werden soll.

Angeben, wie E-Mail gesendet werden soll

Zeigt das Dialogfeld E-Mail-Einstellungen an, in dem Sie angeben können, wie E-Mail-basierte Webfeatures, wie z. B. Behandlungsroutinen für E-Mail-Formulare, E-Mail-Nachrichten an Websitebesucher senden. Sie können in dem Dialogfeld die E-Mail-Adresse des Webservers, die E-Mail-Kontaktadresse, den E-Mail-Server, das E-Mail-Codierungsschema und den Zeichensatz angeben.

Office-Features für die Zusammenarbeit konfigurieren

Zeigt die Verwaltungswebseiten für die Office-Servererweiterungen an, in denen Sie die Office-Features für die Zusammenarbeit, wie z. B. Arbeitsgruppendiskussionen, verwalten können. Diese Option steht nicht zur Verfügung , wenn Office Web Server (OWS) nicht auf dem Computer installiert ist.

Sicherheitseinstellungen nicht übernehmen

Standardmäßig übernimmt jedes Stammweb die globalen Sicherheitseinstellungen des Webservers. Um diese Einstellungen für das ausgewählte Stammweb (und alle seine Unterwebs) zu überschreiben, aktivieren Sie dieses Kontrollkästchen. Deaktivieren Sie dieses Kontrollkästchen, wenn das ausgewählte Stammweb seine Sicherheitseinstellungen von den globalen Webservereinstellungen übernehmen soll.

Dokumenterstellungsvorgänge protokollieren

Ermöglicht dem System, den Zeitpunkt, zu dem ein Dokumenterstellungsvorgang durchgeführt wurde, den Benutzernamen des Autors, den Webnamen, den Remote-Host sowie die Daten der einzelnen Aktionen aufzuzeichnen und diese Informationen im Stammweb in der Protokolldatei _vti_log/Author.log zu speichern. Deaktivieren Sie dieses Kontrollkästchen, wenn Dokumenterstellungsvorgänge nicht protokolliert werden sollen.

Berechtigungen manuell verwalten

Deaktiviert die Funktionen zum Einstellen der Sicherheit mit Hilfe der Verwaltungstools der FrontPage-Servererweiterungen (beispielsweise des FrontPage-MMC-Snapins), sodass mit diesen Tools die Sicherheitseinstellungen des ausgewählten Webs nicht geändert werden können. Deaktivieren Sie dieses Kontrollkästchen, um zuzulassen, dass die Sicherheitseinstellungen mit Hilfe der Verwaltungstools der FrontPage-Servererweiterungen geändert werden.

Dokumenterstellung nur mit SSL zulassen

Ermöglicht den Einsatz von SSL, um zukünftige Webautoren zu authentifizieren. Dies wird empfohlen, wenn Sie derzeit lediglich die Standardauthentifizierung verwenden, bei der Informationen (wie z. B. der Benutzername und das Kennwort eines Autors), die über das Web übertragen werden, kaum verschlüsselt sind. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie SSL für die Dokumenterstellung nicht fordern möchten.

Uploaden von Programmen durch Autoren zulassen

Erlaubt Autoren, CGI-Skripts oder Active Server Pages (ASP) auf das ausgewählte Web zu uploaden. Deaktivieren Sie dieses Kontrollkästchen, wenn Sie verhindern möchten, dass ausführbare Dateien auf das Web geuploadet werden, und um die Risiken, die mit einem unter Umständen fehlerhaften Skript oder mit einem Virus verbunden sind, der auf den Webserver geuploadet wurde, zu vermeiden.